ReferencePlatforms/UnitTestOnly/10.5-Xserve
From MozillaWiki
Contents
Version 1
Install OS
Image machine with standard 10.5.2 Xserve PPC build machine image. The image is actually an Intel image, so we need to remove the installed version of MacPorts
sudo port -f uninstall installed sudo rm -rf \ /opt/local \ /Applications/DarwinPorts \ /Applications/MacPorts \ /Library/LaunchDaemons/org.macports.* \ /Library/Receipts/DarwinPorts*.pkg \ /Library/Receipts/MacPorts*.pkg \ /Library/StartupItems/DarwinPortsStartup \ /Library/Tcl/darwinports1.0 \ /Library/Tcl/macports1.0 \ ~/.macports #Existing mozilla tools are I386 only sudo rm -rf /tools rm ~/.profile #only contained useless things # logout or reboot to pickup changes, otherwise your python installs below won't work
System Preferences
Open System Preferences and in:
- Energy Saver set both times to 'never'
- Spotlight set the main hard drive as a private location to stop spotlight from indexing it
- Desktop and Screensaver set the screensaver time to 'never'
- Dock and set the dock to automatically hide
- Displays and set resolution to 1280x1024@60hz
- Sharing and enable screen sharing and remote login
Nagios
curl -O http://prdownloads.sourceforge.net/sourceforge/nagiosplug/nagios-plugins-1.4.15.tar.gz tar zxvf nagios-plugins-1.4.15.tar.gz cd nagios-plugins-1.4.15 ./configure --prefix=/usr/local/nagios --libexecdir=/usr/local/nagios/plugins make sudo make install sudo make install-root
Runtime requirements
You need to install mercurial, wget and buildbot. Instead of installing macports and xcode tools we are going to use the built in version of Twisted 2.5.0:
curl -O http://mercurial.selenic.com/release/mercurial-1.5.2.tar.gz tar zxf mercurial-1.5.2.tar.gz cd mercurial-1.5.2 python setup.py build sudo python setup.py install
curl -O http://tmrc.mit.edu/mirror/twisted/Twisted/2.5/Twisted-2.5.0.tar.bz2 tar jxf Twisted-2.5.0.tar.bz2 cd Twisted-2.5.0 sudo python setup.py install
hg clone http://hg.mozilla.org/build/buildbot buildbot cd buildbot hg up -C --rev 53 python setup.py build sudo python setup.py install
For WGet:
curl -O http://ftp.gnu.org/gnu/wget/wget-latest.tar.gz tar zxf wget-latest.tar.gz cd wget-1.12 #or whatever version is the latest ./configure make sudo make install
Buildbot Slave
Finally, set up your buildbot slave
mkdir -p /builds/slave cd /builds/slave buildbot create-slave . master:port username password
Setup buildbot start on boot
The existing start-up script (/Library/LaunchAgents/buildbot.start.slave.plist
) will work without modification *if* you create the symlinks for the paths it is expecting, specifically:
mkdir -p /tools cd /tools ln -s /Users/cltbld/buildbot ln -s /System/Library/Frameworks/Python.framework/Versions/2.5 python
From VNC:
- Make sure the resolution is set to 1280x1024. (this is not in the xserve ref image)
- System Prefs -> Accounts -> Login Options
- Set 'Automatic Login' to 'cltbld', enter the password when prompted.